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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

¢ Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

» Bold type is used for the following:

o Keyboard entries that should be typed in their entirety exactly as shown. For example,
“copy file1” means you must type the word copy, then type a space, and then type
file1.

° On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign > Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter’ means to press
the key labeled Enter.

« ltalic type is used for the following:
° Emphasis.
° The titles of publications.

o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then type a
space, and then type the name of the file.

* The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

* The Ribbon occupies the rectangular area at the top of the application window and
contains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Schematic > Line"

This instruction means that you should click the Line command on the Schematic ribbon
tab. An image of the command icon, or a partial view of the ribbon, is often included with
the instruction.
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* The menu bar (located above the ribbon) is a group of the main commands of an
application arranged by category such File, Edit, View, Project, etc. An example of a
typical user interaction is as follows:

"On the File menu, click the Open Examples command" means you can click the File
menu and then click Open Examples to launch the dialog box.

« Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu
To access help from the Help menu, click Help and select from the menu:

* [product name] Help - opens the contents of the help. This help includes the help for the
product and its Getting Started Guides.

* [product name] Scripting Help - opens the contents of the Scripting Guide.

* [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction

The focus of this tutorial is to learn about the use of the EMIT Elements Library and explore how
EMIT's simulation engine runs for larger scenarios.

Key Concepts

* Introduction to libraries in EMIT

Creating libraries and adding components
Using library components in EMIT projects
Tunable filters in EMIT

Understanding how EMIT runs large projects

Project Configuration

We will build on the project begun in Tutorial 4 and use the EMIT Elements Library to complete
the scenario. You can load a completed version of the Tutorial 4 project archive from [Installation
Folder\Win64\Examples\EMIT\Tutorials\Tutorial 4 or work with your own version of the Tutorial
4 project.

Introduction 1-1
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2 - EMIT Libraries

The EMIT Elements Library provides a way to create and store any components and RF
systems that can be used in an EMIT project. The models stored in the EMIT Elements Library
are available for use in any EMIT project and can be archived for storage and for portability to
share libraries between users.

The EMIT Elements Library is controlled from the Component Libraries window. Access it one
of two ways:

¢ From the View menu, select Component Libraries, or
* From the View ribbon, click Docking Windows > Component Libraries.

D Docking Windows =
»*  Status Bar

Project Manager
Message Manager
Properties

L S

Progress

ACT Extensions

5

Cormponent Libraries
Variables L}'
Layers

Mets

Components

Cells
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Component Libraries o =

i =, Favorites
B2 Most Recently Used

ﬁ Divider (LIBRARY: EMIT Bements D
IEI‘ MNew Radio (LIBRARY: EMIT Elemeni
L. New Emitter (LIBRARY: EMIT Elemer
B2 EMIT Elemerts
-l Amplfiers
ﬂj Antennas
- g Cables
- g Circulators
- g Dividers
=g Emitters
=@V Fiters
=@V Isolators
-l Multiplexers
=gl Radios
-l Switches
ﬂj Teminataors
B2 Personal Libraries
ﬂj rando
----- 2, Project Components

< >

Components

A new installation of EMIT includes multiple Ansys libraries containing components that can be
used in EMIT projects. These are permanently locked libraries that cannot be changed by the
user. However, components can be exported into your Personal Libraries, where they are fully
editable.

After making changes to a component, right-click it and select Export to Library to saveitto a
personal library.

EMIT Libraries 2-2
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Reorient
Disable
Enable

Divide

Component Help...

Cut

Copy
Delete

X W %

Export to Library...

Add to Favorites
Place Component
Rename Library Component...

Delete Library Component

View Component Help

= Configure...

Ctrl+ X
Ctrl+C
Delete

L

This makes the component easily accessible across multiple designs and/or projects.

Once stored in a personal library, right-click a component for options to rename or delete it.

EMIT Libraries 2-3
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3 - Adding Components to Libraries

Components added to a library will be available for use in any project containing an EMIT
design. Components can be easily moved from a project to a library.

Suppose we wish to create a filter that will be available in a library.

To begin, insert a low pass filter into the project from the Components window:

=gV Fiters

----- =} Band Pass
----- {=} Band Stop
----- =} File-based
----- {2} High Pass

..... & Low Pass ﬁ
----- £} Tunable Band Fass

----- £z} Tunable Band Stop

Rename the filter to HF Low Pass Filter, then double-click to edit the filter.

The Filter Configuration window appears:

Adding Components to Libraries 3-1
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1 Filter Configuration O X
=} HF Low Pass Filter & |5
T 1T T

0 _

— =20 - —

o & I b
-

i1 L 4
Noise Temperature (K) 290.0 - E
Type Low Pass ~ %

5-40 .
Insertion Loss (dB) 0.0 - ||| =

C ]
Stop band Attenuation (dB) 0.0 = %
Max Pass Band (MHz) 30.0 > 2

Min Stop Band (MHz) 35.0 s 60 b _

“Motes I 1

{This is a place to write handy notes. B 7

_BD I
v by b v by by v b by by
0 10 20 30 40 30 60 70 a0
) Frequency (MHz)
—— HF Low Pass Filter (Filter)

Input the parameters:

 Insertion Loss (dB): 0.0

» Stop Band Attenuation (dB): 80.0
* Max Pass Band (GHz): 30.0

¢ Min Stop Band (GHz): 35.0

Tip:

The Notes field is a useful way to document your library components for future
reference.

To add the filter to a library, right-click on the filter in the schematic and select Export to Library.
This opens a file explorer in the Personallib directory. The location of this directory can be
changed in Electronics Desktop from the menu Tools > Options > General Options > General
> Directories.

Create a folder named “My Example Library” and navigate into that folder.

Next, save the filter in a new library named Filters.aclb:

Adding Components to Libraries 3-2
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B Export to user library *
Save in: | My Example Library j = |-=_-"i£ v
: Mame Status Date modified

Mo items match your search.
CQuick access y

Desktop

Libraries

This -I;'C
=g

Metwork

< >

File name: |Hhers.ac||:| j Save
|

Cancel

Save as type: |ﬁns:.'s Component Libraries (*aclb)

Personallib | Lserlib |

An alert appears, asking if you'd like to create a new user library. Click Yes.

The Component Libraries window updates. Under Personal Libraries, there is now a folder
named My Example Library containing a library called Filters.

This library contains the HF Low Pass Filter:

Elg. Personal Libraries
. -3 My Example Library
' Elﬂ'I Fitters

------ {2} HF Low Pass Fitter

Any changes made to libraries are automatically saved by AEDT and will be available each time
you open an EMIT design.

Adding Components to Libraries 3-3
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4 - Using Library Components in an
EMIT Project

We will use the Ansys Navigation Systems Library to add RF systems to this scenario. The goal
is to demonstrate the use of the library in building EMIT scenarios. The result is not intended to
represent a real-world or realistic scenario.

First, load the project that you began building in Tutorial 4. From the File menu, save the project
as Tutorial 6.

From the Simulation ribbon, launch the Coupling Editor and enable all coupling models:

Coupling

Editor

Simulation

B Coupling Editor O >
' Scene (Antennas/Emitters/Geom... vy gg 12

v 1§l Coupling Data

"= Free Space Path Loss ~ A _3?'
[5] ata2 (‘é’) ? gs _‘L‘{&
GP5 Vg Tap g
— UHF-1 T %z |[s]
D s BB b UHF-2 %o -
Minimum Allowed Coupling (dB) VHF-UHF %o f[s]| T
Global Default Coupling (dB)

*Antenna Tags ”l

<
&

Magnitude (dB)
. N

T P TR S P Ty T

- Free Space Path Loss

P I IR T | | | P T !
40 60 80
Frequency (GHz)

=
]
)
=
=
=1

[z

—— GPS - UHF-1

When you are finished, click the X to close the Coupling Editor.

Using Library Components in an EMIT Project 4-1
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Next, we will add a GPS Rx to the project using a GPS Rx provided in the Navigation Systems
Library.

Most radios in the Ansys Libraries are not intended to represent any specific brand or model of
radio. Instead, they provide a model that is broadly representative of radios used for a particular
function. The parameters are based on typical values averaged over a range of actual hardware
specifications. After adding a radio to an RF System, the user still needs to set up the RF
System's configuration, including the hardware connections and the radio's sampling.

The GPS Airborne Receiver can be found in the Component Libraries window under EMIT
Elements > Radios > Navigation Systems > GPS-GLONASS. Add a GPS Airborne
Receiver to the schematic, and ensure the radio is connected to the previously placed GPS
antenna:

=& EMIT Blements
ﬂj Amplffiers
aj Antennas ]
ﬂj Cables

I =g Circulators

E| ﬂj Dividers Radio +

L 4G Divider GPS
l =@V Emitters GPS Airborne Receiver

I ﬂj Fitters |
g Isolators
H-g! Multiplexers
-l Radios G
a Commercial Licensed Systems
-0 Commercial Unlicensed Systems
[:I Miltary Systems

=- 23 Navigation Systems

= ﬂl GPSGLONASS

[} GLOMASS Receiver

.-} GPS Aibome Recsiver L2
[0} GPS Manpack Receiver
El‘ GFS Receiver

-0} Honeywell HTS100 GPS
@} SIGI - Trimble Force 5 o

EI‘ Trimble THL 3000 WHE-UHF
- ﬂj Transponders
- ﬂ] Weather Radar
----- B} New Radio

Right-click the radio and select Configure to launch the GPS Airborne Receiver
Configuration window.

The radio has 3 bands (L1 CA, L1 P(Y), and L2 P(Y)), each of which has 1 channel. We are only
interested in the L1 CA and L2 P(Y) bands, so disable the L1 P(Y) band.

Using Library Components in an EMIT Project 4-2
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B GPS Airborne Receiver Configuration O x
[} GPS Airborne Receiver v

& Lica 1 . T T . . . .

P & urm O | 1

& Lrm |

o Sampling ]

= 0.5 - -

% 0 o = i

“Motes ||| L _

An Airborne GPS receiver with L1/L2 o 7]

frequencies, The Airborne GPS Rx has 3 1
improved RY selectivity and sensitivity
compared to the Manpack GFS R,

All Rx mixer products are ignored since the IF L i
frequency is unknown. If the IF frequency is
known, mixer products can be added by -0.5
increasing the RF/LO Harmanic order and L 4
selecting Mo Filter instead of Ideal Filter,

=1 -0.75 -0.5 -0.25 ] 0.25 0.5 0.75 1
Ok Cancel

Suppose that the spec sheet for the particular GPS Rx that we will be using provides sensitivities
of-140 and -150 dBm @ -32 dB SNR for L1 CA and L2 P(Y), respectively. In this case, we wish
to adjust the radio model to more reliably represent the performance of the specific hardware
that we will be using. Let's also assume for the analysis that we require reception at sensitivity.
That is, the lowest signal that we wish to receive is at the sensitivity level of the Rx.

We can adjust the generic library radio model to more accurately reflect the specifications of the
particular radio that we will actually use on the platform. The Processing Gain for our model is
specified at the antenna terminal, so we want to apply it to both the broadband noise and the
narrowband noise. Thus, we will make sure Apply PG to Narrowband Only is False for both
bands.

Expand the nodes under the GPS Airborne Receiver radio node and select the Rx Spectral
Profile.

For the L1 CA band, apply the following settings:

* Min. Receive Signal Pwr (dBm): =140 dBm
* SNR at Rx Signal Power (dB): 16.32
¢ Processing Gain (dB): 10.0

Using Library Components in an EMIT Project 4-3
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* Apply PG to Narrowband Only: False
» Saturation Level (dBm): 0.0
¢ Perform Rx Intermod Analysis: False

For the L2 P(Y) band, apply the following settings:

* Min. Receive Signal Pwr (dBm): =150 dBm
* SNR at Rx Signal Power (dB): -32.0

* Processing Gain (dB): 10.0

* Apply PG to Narrowband Only: False

e Saturation Level (dBm): 0.0

e Perform Rx Intermod Analysis: False

The spectral profiles for the L1 CA and L2 P(Y) bands are shown on the left and right in the figure
below, respectively.

[} GPS Airborne Receiver o) L1 PY) ] A
v @ Lca v @ L2PY)
T Spectral Profile ] T Spectral Profile ]
A n’rr Rx Spectral Profile “!rr Rx Spectral Profile
Y. Rx Selectivity 2 Sampling I
L1 P(Y) ] v W
Bl @ Bl @
Sensitivity Units dBm e Sensitivity Units dBm W
Min. Receive Signal Pwr (I| Min. Receive Signal Pwr |
SMR. at Rx Signal Pwr (dB) 16.32 = SMR. at Rx Signal Pwr (dB) -32.0 =
Processing Gain (dB) 10.0 - Processing Gain (dB) 10.0 =
Apply PG to Marrowband Cnly  [_] False apply PG to Marrowband Cnly [ ] False
Saturation Level {dBm) Saturation Level (dBm)
Perform R Intermod Analysie [ | False Perform R Intermod Analysiz [ ] False
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Plot the L1 CA band to see the Rx susceptibility spectral profile for the Rx on the L1 frequency.
You may need to adjust the plot axis limits in the Plot configuration panel to get the exact plot
shown below.

v B
T T T T T T T T T I T I T I T

0
,.E i
o -30 ~ —
o i
L
i) i
o
3 i
2=
[ .
% 100
i -

-150 ] 1 | 1 | 1 | 1 | 1 | 1 | -
1.555 1.56 1.365 1.57 1.575 1.58 1.585 1.59 1.595
5 Frequency (GHz)
— L1 CA 1.57542 GHz (Rx)

Notice that the Rx response only contains the in-channel response (that is, no spurious
responses are included). This is because for a generic radio model, the IF of the Rx and the
location of other spurs is not known. If you have this information available for a specific radio to
be used, you will want to add this to the generic radio model from the library.

Once you've modified the generic model in your project to represent the actual hardware more
closely, you may want to preserve this model in the library for future use in other projects.

Rename the generic radio to something more descriptive. For this example, name it Radio
World Model ABC.

Using Library Components in an EMIT Project 4-5
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Radio *

Radio World Model ABC

VHF-UHF

Save the modified radio to the My Example Library folder you created earlier. First, right-click on
the component and select Export to Library. Navigate into the My Example Library folder and
save the new library as Radios.aclb.

Using Library Components in an EMIT Project 4-6
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B Export to user library et
Save in: | My Example Library j &= = ER-
z‘1 Marme Status Date modified
Fi . . ':.:".] 71/ H
Cuick acoess L] Fllters aclb.semaphore < /11,2023 10:09 A
| | Filters.aclb () 71172023 10:09 A
Desktop
™
Libraries
This PC
Network
£ >
File name: Hﬂdius.adb j Save
Save az type: |f-‘-ns'_.'s Component Libraries (*.aclb) j Cancel
PersonalLib | Userlib |

Upon clicking Save, an alert appears asking if you'd like to create a new library. Click Yes.

The Component Libraries window updates to show two libraries in the My Example Library
folder:

Elg- Perzonal Libraries
' Ela My Example Library

Eﬂj Filters
i L.{&F HF Low Pass Fitter

ElﬂJ Radios

Next, navigate to the Schematic ribbon and add three new radios to the project using Radio
> Library.

Using Library Components in an EMIT Project 4-7
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[} Radio - v -
Mew Radio
Library... I/\\r

Radio World Model ABC
GPS Airborne Receiver

The Select Radio window appears, containing the EMIT Elements library.
All three radios to add are under Military Systems > UHF.
Add the radios named HAVEQUICK Vehicular, UHF Vehicular, and UHF_VHF FM Comms.

B ' Select Radio >

|:| Commerdal Licensed Systems ~
|:| Commerdal Unlicensed Systems

=123 Military Systems

=@ coL

- HF

ﬂj Multiband

ﬂj S-Band Telemetry

-l UHF

----- [ cr-123

----- [} CRD-120-205

----- B} HAVEQUICK Airborne

----- [} HAVEQUICK Manpack

[} HAVEQUICK Vehicular |

""" 1*F LIHF Ground
""" [} UHF Manpack
[} UHF Vehicular

------ [} UHF_VHF FM Comms
VAF
-2 Mavigation Systems v

Cancel

Next, we will modify the radios' samplings and the configurations for these RF systems to use
our existing antennas.

Open the configuration window for the HAVEQUICK radio. We want to operate the HAVEQUICK
system in its random frequency hopping mode, so set the HAVEQUICK Vehicular radio's
Sampling parameters to the following:

Using Library Components in an EMIT Project 4-8
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+ Sampling Type: Random Sampling

» Specify Percentage: False

* Max # Channels/Range/Band: 1000

e Seed:0

* Frequency Ranges: Insert two rows.
¢ Row 1: 225 Min (MHz) and 250 Max (MHz)
¢ Row 2: 350 Min (MHz) and 400 Max (MHz)

Note:

The unit of measure displayed in the configuration window is determined by settings in
Tools > Options > General Options > EMIT. You may need to convert the numbers
above.

Using Library Components in an EMIT Project 4-9
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[ HAVEQUICK Vehicular

> @y Band (&)
» 6‘ Band (Rx)

| Sampling

b

Sampling Type Random Sampling ~

Spedfy Percentage [ ] False

LIl

Max # Channels/Range/Band 1000

Seed ] =
Total Tx Channels 301
Total Rx Channels 301
TFreguency Ranges

Min (GHz) Max (GHz)
o 0.225 0.25
« 035 0.4
Insert Row Remove Selected Rows

Connect this radio to the UHF-1 antenna.
Open the configuration window for the UHF_VHF FM Comms radio.

Radios in the Ansys libraries with multiple bands have all the bands disabled by default. This is a
result of the radio models being generic and often containing more capabilities than is required
for a simulation. In this tutorial, we want all the bands enabled for the UHF_VHF FM Comms RF

System, so enable them all.

Using Library Components in an EMIT Project 4-10
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Set the Sampling parameters to the following:

Sampling Type: Uniform Sampling

Specify Percentage: False

Max # Channels/Range/Band: 1000
Frequency Ranges: Insert two rows.

* Row 1: 146 Min (MHz) and 146.5 Max (MHz)
¢ Row 2: 420 Min (MHz) and 421 Max (MHz)

Note:

The unit of measure displayed in the configuration window is determined by settings in
Tools > Options > General Options > EMIT. You may need to convert the numbers
above.

Using Library Components in an EMIT Project 4-11
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[ UHF_VHF FM Comms
v [ VHF & FM Band

> @y Tk 144-148 MHz
v [ UHF & FM Band

> @y Tk 420-450 MHz
v [ VHF Rx FM Band

> @ Rx 144-148 MHz
v [l UHFRx FM Band

> @y Rx 420-450 MHz

|_._;l,. Sampling

!:‘fl

Sampling Type Uniform Sampling e
Spedfy Percentage [ False
Max # Channels/Range/Band 1000

Total Tx Channels 17
Total Rx Channels 17

4k

TFrequency Ranges

Min (GHz) Max (GHz)
" 0.146 0.1465
o 042 0.421
Insert Row Remove Selected Rows

Connect this radio to the VHF-UHF antenna.

The UHF Vehicular radio will be operated in full-duplex mode using FSK to receive on channels
from 250 to 259.75 MHz and to transmit at a +100 MHz offset from the selected Rx channel.
Enable the FSK (Tx) bands under the UHF Vehicular radio node. Select the FSK band and set
the Tx Offset to 100 MHz. Leave the Sampling parameters as their defaults.

Insert one row into the Frequency Ranges, with a 250 Min (MHz) and a 259.75 Max (MHz).
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Note:

The unit of measure displayed in the configuration window is determined by settings in
Tools > Options > General Options > EMIT. You may need to convert the numbers

above.

B} UHF Vehicular

[} UHF Vehicular

“Modulation

[] Falze

Channel Bandwidth (GHz)  [0.000075

Use Emission Designator

4k

Modulation FSK e
Bit Rate (bps) [125000.0 H
Sidelobes |4 H
Freq. Deviation (GHz) |E|.I:|EII:|DIIIE = |
FSK Type 3-F5K e

“Channel Frequencies

4k

Stop Frequency {GHz) |I:|.4 |

Channel Spacing (GHz) [0.00075

Tx Offset (GHz) 0.1 H

Start Frequency (GHz) [0.225

4k

g FSK (T & FSK (T
PSK () ] PSK (T) [l
MSK (T) ] MSK (i) ]
|5 Sampling [ Sampling
88" WO © ()
Use DD-1494Mode [ | False Sampling Type Uniform Sampling ~

[] False

Max # Channels/Range/Band |1IJIIIEI

Specify Percentage

4k

Total Tx Channels 13
Total Rx Channels 13
TFrequency Ranges
Min (GHz) Max (GHz)
o 0.25 0.25975
Insert Row Remove Selected Rows

Connect this radio to the UHF-2 antenna.

The schematic should now look like the following:
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T GPS
Radio World Model ABC
] UHF-1
HAVEQUICK Vehicular
T UHF-2
UHF Yehicular
I VHF-UHF

UHF_VWHF FM Comms

If other specifications on actual radios' performance were available, we would also want to refine
these generic radio models. Remember that the scenario we are creating is not intended to
represent a real operational scenario.
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5 - Tunable Filters

Next, we will add tunable (aka. tracking) bandpass filters to the UHF Vehicular radio. Tracking
filters automatically change their passband characteristics with changes to the Tx and/or Rx
frequency of the radio. EMIT supports bandpass as well as bandstop tracking filters.

In the case of the UHF Vehicular system in our scenario, the full duplex operation with 100 MHz
separation between Tx and Rx channels requires separate filters for the Tx and Rx paths of the
radio and EMIT supports this.

The easiest way to add components to an RF system is using the Reorient and Reposition
actions in the Schematic Toolbar. Select the UHF-2 antenna and click Reposition.

This will automatically disconnect the antenna from the radio. Next, add a Circulator to separate
the Tx and Rx paths. To add a Circulator to the diagram, click the Circulator button on the
Schematic ribbon. With the circulator still selected, connect it to the radio’s output port. We will
use the default parameters for the circulator in this tutorial. The connection should look like the
following:

UHF Vehicular

Circulator

Next, we will add tunable filters. Add a filter by clicking the Filter button on the Schematic ribbon
and selecting Tunable Band Pass from the drop-down menu.

{=} Filter - B ]

Band Pass

Band Stop

File Based

High Pass

Low Pass

Tunable Band Pass
Tunable Band Stop b

Repeat this to add a second tunable band pass filter. Click Reposition to connect it to the
circulator’s other port.

Tunable Filters 5-1
Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with EMIT - Tutorial 6

UHF Vehicular iy
Circulator e

Finally, add a second circulator. By default, circulators are added to the schematic with the
single port on the left and the two port side to the right. We can change this quickly by selecting
the circulator and clicking Reorient.

Click Reposition until the circulator is connected as shown below.

UHF Vehicular L .

Circulator TR Circulator 2
Fitter 2

As before, we will use the default parameters for the circulator in this tutorial.

Finally, select the UHF-2 antenna and click Reposition until it is connected to the second
circulator:

UHF-2

UHF Vehicular iy

Circulator T Circulator 2
Fitter 2

The components have been added to the schematic, but their properties are undefined. Double-
click the top filter to open its Filter Configuration window.

Tunable Filters 5-2
Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with EMIT - Tutorial 6

Set the properties as follows:

* Insertion Loss (dB): 0.5

« Stop Band Attenuation (dB): 40.0

* Lowest Tuned Frequency (GHz): 0.35
» Highest Tuned Frequency (GHz): 0.36
e Percent Bandwidth (%): 10.0

» Shape Factor (30dB/3dB): 2.0

Double-click on the second filter in the schematic to open its Filter Configuration window.
Set the properties as follows:

* Insertion Loss (dB): 0.5

» Stop Band Attenuation (dB): 40.0

» Lowest Tuned Frequency (GHz): 0.25
* Highest Tuned Frequency (GHz): 0.26
» Percent Bandwidth (%): 10.0

* Shape Factor (30dB/3dB): 2.0

The properties for both filters are shown below.
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{2} Tunable Band Pass

{2} Tunable Band Pass

Percent Bandwidth {%&)
Shape Factor (30dB/3dB)

& @ & @

Moise Tempera ture (K] |290.0 H Moise Tempera ture (k) |290.0 H
Type Tunable Bandpass e Type Tunable Bandpass ~
Insertion Loss (dB) |E|. 5 = Insertion Loss (dB) |I:|.5 =
Stop band Attenuation (dB) |4|:|.I:| > Stop band Attenuation (dE) |4I:|.I:| =

Lowest Tuned Frequency (GHz) |E|.35

Lowest Tuned Frequency (GHz) |I:|.25

Highest Tuned Freguency (GHz) |D.36

|
|
|
> | Highest Tuned Frequency (GHz) |E|.26
|
|

*Notes

| 10,0 = Percent Bandwidth (%) | 10.0 S
|20 2 Shape Factor (30dB/3dB) [2.0 3
“Motes
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6 - Running the Simulation

Before running the simulation, we must ensure that the coupling is set. From the Simulation
ribbon, open the Coupling Editor. Under Free Space Path Loss, ensure Antenna A and
Antenna B are set to (all).

© Scene (Antennas/Emitters/Ge...
v il Coupling Data

%= Free Space Path Loss
(5] ata3
& e e
Enabled True
Antenna A | (all) >
Antenna B | (all) >
T Propagation Modifiers

Next, select ata3 settings and ensure that ata3.s2p is selected for Filename. This file can be
found in [Installation Directory]Win64\Examples\EMIT\Tutorials\Tutorial 4.
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" Scene (Antennas/Emitters/Ge...
v 1%l Coupling Data
%z Free Space Path Loss
[5] ata3
& e e
Enabled True
Filename ata3.sZp
Enable EM Isolation [] False
“Port-Antenna Assignment
1 |UHF-1 o
2 |VHF-UHF o
*Motes

When you are finished, click the X to close the Coupling Editor.
Next, we run the simulation. From the Simulation ribbon, click Analyze.

The analysis setup launches:
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Tutorial & - EMIT Design1 [m] »
4 &+ L) w + 4 H 1 # & =B B ©
Run EMIMargin  Availability ~Sensitivity — Desense Reset Zoom FitMatrix  ShowHidden Combinations Expand Text Save Defaults Restore Defaults Help
ByProblemType By EM[Margin By Avalabiity By Desense
F e
Z.;;“ & _ r__ [ all Rx InChannel [=] all Rx Out-of-Channel
§ &8
o :5‘? & 4$ [ Tx Fundmental [ Tx Fundmental
£ ’
Rx g & ¢
Tx Harmonic/Spurious Tx Harmonic/Spurious
Radio World Model ABC E w| w| .
F |y T [ Intermod [ ntermod
HAVEQUICK Vehicul ¢
EQ ehicular E BEE .
] Broadban
UHF_VHF FM C: ¢
S EIEIE .
UHF Vehicul :
ehicular E NI _ _ =
Result Plot ~
Title [ -
Il - I Title Font A
N to 1 Combination Limit: v @ & ~Show Legend [ True
Total Channel Combinations: 110,087 1 T T T ] Show EMI Thresholds True
Channel Combinations Analyzed: (] 4 Lock Axes [ False
= 1| rxeas
Transm EMI  Combos Receive EMI  Combos =05 R -
R [11]
4 110K v 10K A A Label Font
(o3 100K (o3 662 % xis Label Fon A
(3 6K = 100K 2 0 * Axis Tick Label Font A
3 4K o3 6K =
& 1K ] Major Grid Line Style Mane ~
3 s ] "Background Color [255, 255, 255] (255)
BB Power for Plots Unit | hertz ~
B8 Power Bandwidth (Hz) [1.0
J ISP R I EE SIS AVERTINN IR ST R
— el -0.75 -0.5 -0.25 [ 0.25 0.5 0.75 1
| Frequency (MHz)

While it is not the intent of this example to examine the results of this scenario in any detail, it will
be used to discuss several aspects associated with running larger simulations in EMIT. This is
not a particularly large simulation, but it is large enough to demonstrate several features of EMIT
designed to deal with large simulations.

At the bottom of the Scenario Matrix, the total number of channel combinations in this scenario is
110,067:

M to 1 Combination Limit:

Total Channel Combinations: 110,067
Channel Combinations Analyzed: i

This is the number of Tx/Rx channel pairs that EMIT needs to analyze to complete all of the 1-
on-1 simulations. If we slide the N-to-1 Combination slider all the way to the right or deselect the
check box, the number balloons to 27,463,308 since multiple channel combinations and
permutations must now be accounted for.
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N to 1 Combination Limit: l
Total Channel Combinations: - 21,463,308
Channel Combinations Analyzed: i

A simulation with this many channel combinations could take a long time to run in EMIT, but
EMIT has several features that make a potentially time-consuming simulation more palatable:

« EMIT's computational engine can take advantage of computers with multi-core
processors to run parts of the simulation in parallel. The user can specify the number of
cores (also called threads) to use for the simulation. By default, EMIT uses all available
cores, but this is not always desired as it will leave few system resources for other tasks.
To control the number of cores used for the simulation in AEDT, go to Tools > Options >
General Options > Desktop Performance. The maximum number for the base license
is 4. Additional cores can be specified if you have an Ansys HPC. This can be controlled
from Tools > Options > HPC and Analysis Options.

» EMIT simulations can benefit from the use of GPUs (requires an Ansys HPC license).
However, the benefits are problem-dependent. In projects that use tunable filters, as this
one does, there is little benefit to utilizing a GPU.

+ EMIT simulations can be paused at any time by the Stop button in the simulation progress

window. When a user clicks Stop, EMIT saves the current results and pauses the run.
The next time the simulation is run, EMIT will resume the simulation.

EMIT

Running (349,606 of 21,463,308)

Stop

Running the entire simulation at this point will take a long time to run with Multiple Tx's
simulations active. When performing N-on-1 simulations (that is, those associated with the [N to
1] column of the Scenario Matrix), all potential Tx/Rx channels must be analyzed. Even for
systems with a modest number of operational channels this can result in a very large number of
interactions for EMIT to compute.

You can activate/deactivate Tx/Rx pairs for simulation by pressing Ctrl and clicking the
corresponding entry in the Scenario Matrix. Deactivated entries in the Scenario Matrix appear as
gray icons. Entire rows/columns in the Scenario Matrix can be enabled or disabled (as well as
run or hidden) via the Row or Column menu accessed by right-clicking on the RF System name
in the Scenario Matrix.
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Suppose we wish to simulate possible interference in the Radio World Model system when only
the UHF_VHF FM Comms and UHF Vehicular systems are transmitting simultaneously. This is
accomplished as follows:

1. Deactivate the HAVEQUICK Vehicular versus Radio World Model ABC square by
pressing Ctrl and left-clicking on its Scenario Matrix square. Deselect Enabled. The
square grays out:

Rx

Radio World Model ABC < vl w

HAVEQUICK Vehicular F: L L L 4

UHF_VHF FM Comms ; L W L

UHF Vehicular < wl vl w

3 £
£ 5
oy _‘!;E-' &
Tx 'Ej'r < 03‘
| >/S & F
o /& ;: Py
R F/FE £ 3
Radio Warld Mode| ABC - . .
=, J\r J"r
HAVEQUICK Vehicular | « R :
EQ § [* Run % S
UHF_VHF FM Comms & # " "
ls S
IUIHF Wehicular - . . G
nlsr >~

The analysis completes very quickly, as there are only 502 channel combinations.

M to 1 Combination Limit:

Total Channel Combinations: 21,330,106
Channel Combinations Analyzed:
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Since we are only analyzing the Radio World Model, we may also wish to hide the other entries

in the Scenario Matrix. Entire rows and columns can be hidden by right-clicking an RF System
name and selecting Hidden from the Row or Column menu.

3 &
£ ; & @éﬂ
A & " R 4] &
& & F . & &£ F
- . £ )
| Sfg & & ol &8
& )4 ; il & &
Rx /s & ¢ R $/§ £ 3
— Column
Radio Warld Model| ABC : Radio World Model ABC : > =
io Waorl = EN I\g ,\: A :\.. :\.
- " e HAVEQUICK Vehicular e B el vl «
HAVEQUICK Vehicular $ I\, I\, :r" EQ A :k !\. :k
UHF_VHF 72~ ¢ UHF_VHF FM Comms e M owl| v
Row * [ Fun [ TAQY |¥ | ¥
UHF Vehicular ' Enable ¢ UHF Vehicular ,.-__ :u I\; :u
Disable —
Hidden I:}

e P

Run
Enable
Disable
Hidden

To restore the display of hidden rows and/or columns, click the Show Hidden button on the

Scenario Matrix toolbar:

1

Showe Hidden

3

Feel free to run various interactions in this scenario and explore the results. You'll find that there

are many interference problems, and it might be interesting to explore the various phenomena
causing the interference. Just keep in mind that this example isn't representative of a typical or

even realistic cosite scenario.

When you are finished, save your project.

This concludes EMIT Tutorial 6.
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